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XMetaL Instructions for NRC RP Editors
Set manuscript information
1. General information
1.1. Definitions

Element: A strictly defined section of information. Every element has a start and end "tag",
and may contain other elements. For example, the abstract in the manuscript is listed as an
element with the start tag <abstract>, followed by the text of the abstract, and then the end
tag </abstract>. The list of elements that is available for you to insert is context sensitive
to the location of your cursor. See "View>Insert Element".
Attribute: a qualifier that contains additional information about the element. For example,
the attributes on the abstract include the language (English or French) and the source
(Author or Translator). To see the attributes associated with an element, place your cursor
within that element and go to "View>Attribute inspector".
Entity: a virtual storage unit that can contain text, graphics, or sound clips, or can
represent a non-ASCII character, such as the copyright symbol. Begins with an ampersand
(&) and ends with a semi-colon (;), i.e., "&micro;" for the µ sign.
Internal link: forms a relationship between two or more sections of text within the
manuscript such that, by "clicking" on a section of text defined as an "intlink", the cursor
will be sent to the other section of text with the same ID number (IDREF) .
IDREFs: used to identify relationships within the manuscript. Each relationship is assigned
a unique combination of numbers and (or) letters called the "IDREF", which links two or
more sections of text within the manuscript (See also sheet titled "ID Syntax"). See
additional instructions below for callouts with multiple IDREFs.
The HTML program places figures and tables where they occur in the XML file. So,
although 3B2 will place figures and tables based on the location of the first reference, the
HTML will actually retain the document order. Keep this in mind if moving table and
figures references.
Certain empty tags must remain within the document; do not delete the following:
<idbox></idbox> tags, generated on export from eXtyles, at the front of the document.
<no></no> tags at footnotes and equations.
<graphic></graphic> tags.
1.2. Save backup of exported file

NOTE: the manuscript number should be lower-case on all versions of the manuscript (i.e.,
"b" for b05-017).
Open exported XML file.
"File>Save As" with suffix "$export" (e.g., b05-017$export.xml).
NOTE: the manuscript letter should be lower-case.

Close that file and move it to the Original folder.
Re-open working manuscript file (e.g., b05-017.xml).
1.3. Access XMetaL Help

Go to the drop-down menu "Help>Contents" and browse for topic OR
Go to XMetaLAuthorUsersGuide.pdf in the BlackBook folder
1.4. Change view mode

See also "XMetaL views and workspace setup" section below.
Go to View menu and select Plain Text, Tags On, or Normal View OR
Use the three buttons in the bottom task bar

.

1.5. General information

Do NOT open any file in XMetaL unless the PHYSICAL FILE (folder) is on your desk.
Documents in XMetaL can be opened at more than one work station at a time. This rule
will avoid more than one person working on the same manuscript at any given time.
If you insert an element, the replacement text that appears (i.e., {bold}) will disappear once
you start typing.
Generated text (pale blue highlighted text) cannot be edited and is for ease of reading or to
represent text that will also be generated in print layout. The generated comma at the end
of keywords and mots clés will be replaced by a period in the final copy, so do not add an
additional period while editing.
A numbered list is always displayed as "1." or "a." in XMetaL. If the attribute value for the
numbered list is changed (i.e., to parentheses "(a)"), the new list style will not be visible in
XMetaL but will print correctly.
Both "Administrative Information" at the top of the manuscript and "RP article
information" are generated during export from eXtyles, and both contain information used
by 3B2 to create the manuscript ID box, the citation line in the footer, etc. Please ensure
that all information in both locations is correct; if the journal name needs to be corrected,
it must be corrected in both locations. (See also section "Set RP article information and
XML properties").
To enter small caps, it is necessary to use only lower case within the <smallcap> tags
(similarly to WordPerfect).
1.6. XMetaL views and workspace setup

Normal View (CTRL+SHIFT+W, View>Normal View, or View button
that looks similar to a word processing document.

) is a display

Tags On View (CTRL+SHIFT+O, View>Tags On View, or
) displays Normal View
with the XML start and end tags. You can mouse over a start tag to see attribute
information.
Plain Text View shows the plain text of the XML (rules checking is not on in this view, so

you can easily invalidate a document; it can also take a long time to go back to Normal
view if there are a lot of equations or figures) (View>Plain text view, or
).
Toolbars can be turned on/off by going to View>Toolbars or by right-clicking in the grey
area of the toolbars and selecting from the list. You will need the Standard, Formatting,
and NRC RP toolbars.
NOTE: Do NOT use the "Special Characters" or "Symbols" toolbars, as these do not
output the proper symbols. Instead, use the "NRC Characters" and "NRC Symbols"
toolbars.
Turn on or off any toolbar by selecting View>Toolbars OR
Turn on or off any toolbar by right clicking in the toolbar space above document.
You can open more than one file at a time. Each file can be accessed by clicking on the
tabs at the bottom of the screen.
Remember to close all files before closing the XMetaL program; otherwise, each file will
be saved and regenerated whenever XMetaL is reopened, and this may take some time.
The context bar (bottom left of screen) indicates the nesting path to the element where the
cursor is located. This is useful when checking a heading level or identifying whether
punctuation is within <italic>, etc.
The Attribute Inspector is for editing attributes.
Turn Attribute Inspector on by going to View>Attribute Inspector or by using
SHIFT+F6.
The Element Insertion list is for inserting or changing elements.
Turn on the Element insertion list by going to View>Element Insertion or using
CTRL+SHIFT+I.
1.7. Track changes

There is no compare documents feature in XMetaL, so changes that the author should see
need to be tracked while they are being made.
"Track changes" must be reactivated every time XMetaL is opened if it is to be used.
Only what is shown on the screen will be transfered to the PDF file for the author to see.
For more information on who made changes or the date of changes, go to "Plain Text"
mode, where the changes are tracked as Processing Instructions (e.g., "xm-deletion_mark
author="simpsonre" time="20050712T135541-0500")".
Go to Tools>Track Changes to turn on automatic redline and strikeout while editing.
Do the same thing (Tools>Track Changes) to turn track changes off.
To accept or reject the changes, go to Tools>Accept or Reject Changes.
To turn on the toolbar for change tracking, go to View>Toolbars and select the
Reviewing toolbar.
1.8. Insert an element

Place the cursor where the element is to be inserted.
Open the element insertion list by going to "View>Element List" or by using "CTRL
+SHIFT+I".
At the bottom of the "Insert Element" palette, make sure the "insert" button has been
chosen (not the "change" button).
Double-click on the element in the "Insert Element" list that you want to insert (or
select element and click "Apply").
1.9. Change an element into another element

Only certain element changes are allowed within the manuscript (for example, in the
reference section, a "book" can be changed to a "thesis" and vice-versa); these allowed
elements will be visible in the "insert element" list when the lower left "Change" radio
button has been chosen.
Place the cursor in the text between the open and close tags of the element that will
be changed (do not select the tags).
Make sure the "Change" button has been selected at the lower left of the "Element
List".
Select the element to "change to" from within the "Insert Element" list and doubleclick to change (or select the element and click "Apply").
1.10. To split and join elements

Put your cursor where the element will be split into two elements and hit the "Enter"
key (for example, to start a new paragraph in the middle of a paragraph).
Only certain elements may be joined together; it is not possible to perform a "join" that
would invalidate the document.
To join an element to its preceding element, put your cursor just inside the start tag
and hit the "Backspace" key (this will delete the tag and join the elements together).
1.11. Comments/Queries

Comments and queries to the author go in a <query> or <layout-instr> tag. These will
appear bold, underlined, and with a grey background. When the PDF is created for the
author, the grey background won't be visible. Sometimes editing is easier if the comments
are hidden.
WARNING: Comments/queries cannot be placed inside certain tags or an error in the
metadata file will result. Do NOT place comments/queries inside the following tags:
<title></title>, <fname></fname>, <mname></mname>, <lname></lname>, <day></
day>, <month></month>, <year></year>, or <keyword></keyword>. When inserting a
query near these tags, switch to "Tags-on" view and make sure the query is either before
the opening tag or after the closing tag.
Remember to include "Comment to author (instructions)" (near top of manuscript) and
"CrossRef/PubMed instructions to author" (near reference) queries with each manuscript.

For easy reference, queries/comments are automatically numbered in the order that they
appear in the text.
To show or hide all comments, click

from the NRC RP toolbar.

To show or hide one comment, switch to Tags On view and click the + or – sign in
the start tag of the comment you want to hide or show.
To insert a comment to the author, go to the "Insert Element" list and select <query>.
To insert a generated text for common author queries:
Insert a <query> from the "Insert Element" list.
Turn on the Queries toolbar by right clicking in grey area of toolbars and
selecting Queries.
Use the numbered buttons, the arrows, or the circle or triangle on the Queries
toolbar to insert generated text for common author queries.
To view a short description of the generated text queries, hover the mouse over the
Query button, or see Author_queries.xml for reference.
1.12. Table of contents

XMetaL has a navigable table of contents (ToC) that is generated from heading levels 1
and 2 in the manuscript.
To show or hide the ToC, click the

button in the NRC RP toolbar.

You can change the size of the ToC window by putting the cursor on the dividing
line between the ToC and the main document, then clicking and dragging to make
the ToC smaller or larger.
1.13. Bookmarks

You can insert multiple bookmarks in a document to aid in navigation.
Please ensure all bookmarks are deleted prior to sending the file to layout.
To insert a bookmark, click

in the NRC RP toolbar.

To navigate to the next bookmark, click the
To navigate to the previous bookmark, click the
To delete all bookmarks, click

in the NRC toolbar.
in the NRC toolbar.

in the NRC RP toolbar.

To delete one bookmark, switch to Tags On view and delete that whole bookmark
tag (i.e., <?>).
2. Set RP article information and XML properties
2.1. Set RP article information using the Form entry

Both "Administrative Information" at the top of the manuscript and "RP article
information" are generated during export from eXtyles, and both contain information used
by 3B2 to create the manuscript ID box, the citation line in the footer, etc. Ensure that all
information in both locations is correct; if the journal name needs to be corrected, it must
be corrected in both locations.
Ensure NRC RP toolbar is visible: View>Toolbars, check box beside NRC RP.
Click on

button in toolbar.

Select journal acronym from drop-down list.
Select article type from drop-down list.
Select issue type from drop-down list.
Enter starting page number.
Select paper version from the drop-down list.
Click OK.
2.2. Assign topics

Certain manuscripts may have topics assigned to them by the editorial office. To insert a
topic for a manuscript, follow these instructions:
Switch to "Tags-On" view.
Place cursor just after closing </subjcat> tag in "Administrative Information" box at
top of manuscript.
Use "Insert Element" list to insert <topic_cat> tags.
Go to "Attribute Inspector" to select "Topic" from drop-down list.
To insert additional topics:
Place cursor just after closing </topic_cat> tag (looks like a backward-pointing
arrow/box).
Insert additional <topic_cat> tags using "Insert Element" list.
Select "Topic" in "Attribute inspector" for each set of <topic_cat> tags.
2.3. Assign J-Number

Either the EA or the PO can insert the J-Number (CJFAS).
Place cursor just after closing <date> tag in Administrative Information box at top of
manuscript.
Using the "Insert Element" tool, insert <edofficeno> tags.
Enter J-Number between <edofficeno> tags.

3. Edit text
3.1. Cut, copy, and paste

Note: There are rules regarding where one can cut, copy, and paste within an XML
document. To ensure the document is not invalidated, pasting is only allowed where valid
in the document in Normal or Tags On view. For example, you cannot cut and paste just
the tag, but you can cut and paste the tag and its entire contents by clicking on the start or
end tag itself in Tags On view. You can also collapse a tag to hide its contents from view by
clicking on the small minus sign in the start tag.
NOTE: Cutting, copying, or pasting in Plain Text View may invalidate the document and is
not recommended.
IF copying or cutting and pasting text that does NOT have any tags,
THEN
Select the text, use CTRL+C and place the cursor where you want to insert, then use
CTRL+V OR
Select the text and right-click to copy and paste OR
Select the text and drag and drop to the destination.
IF copying or cutting and pasting the tag and its entire contents,
THEN
Turn on Tags On View using buttons on the bottom task bar OR Select "View>Tags
On" from the drop-down menu.
Click on the start or end tag to select the tag and its entire contents.
Cut or copy and paste as you would for plain text (see above).
Differences between XMetaL and other word processing programs:
No space is added after the inserted text when pasting in XMetaL.
After pasting text, the cursor will appear at the start of the inserted section in XMetaL.
3.2. Insert Résumé/Mots clés if necessary

If the Résumé is received after the file has been exported from Word, the EA will export
individually or in batch. The EA will then notify the PO that the résumé is available (files
will be named by date).
Go to exported file (batched file will be named by date, or select the re-exported
manuscript file if exported individually).
Select Résumé/Mots clés (look for the manuscript number at beginning of text if it
was a batch export), including start and end tags (NOTE: the tags will say <abstract>
and <keyword>, even for French).
Cut the selected Résumé/Mots clés (CTRL+X).

Go to your edited XML manuscript, and select "Tags On" view.
Place cursor after the closing Abstract tag or the closing key words tag (if present).
Paste the Résumé/Mots clés (CTRL+V).
Remove the manuscript number from beginning of Résumé text if necessary.
If this was the last Résumé in a batch export, delete the dated batch file.
Sometimes you will not have the résumé before the file goes to layout.
IF the résumé has not been received from the translator before the file goes to initial
layout,
THEN insert a temporary placeholder, as follows:
Place cursor immediately after closing </Keywords> tag (or after closing </
Abstract> tag if no keywords are present).
Using the "Insert Element" palette, insert a set of <abstract> tags.
Place cursor between opening and closing <abstract> tags that were just inserted.
In "Attribute Inspector", set language to "fr" (French) and set source to "Author" or
"Translator", as appropriate (see section below, "Set Resume Source").
NOTE: generated text will be changed to "Résumé" when language is set to "fr"; tags will
be unaffected.
Insert dummy text between <abstract> tags (i.e., "French French French...") to
enable layout to set approximately the correct length for the résumé.
IF mots clés will also need to be inserted,
THEN set up as follows:
Place cursor immediately after closing French </abstract> tag.
Using the "Insert Element" palette, insert a set of <keywords> tags.
Place cursor just after opening <keywords> or just before closing </keywords> tags.
NOTE: do not be confused by the individual <keyword> tags (vs. the collective
<keyword"S"> tags)!
In the "Attribute Inspector" palette, set the language to "fr" for French.
NOTE: generated text will be changed to "Mots clés" when language is set to "fr"; tags
will be unaffected.
Using "Insert Element" palette, insert one set of <keyword> tags for each mot clés
(see section below, "Insert a Keyword").
Insert text (or dummy text) for French keywords between <keyword> tags.

3.3. Set Resume source (for "Traduit par la Rédaction")

Place cursor in text of Résumé (between the <abstract> start and end tags).
Make sure Attribute inspector is turned on (View>Attribute Inspector).
In the "Attribute inspector", place the cursor at the drop-down menu in the cell to the
right of "source".
From the drop-down menu, select the source as "author" or "translator"; this will
determine whether 3B2 (layout) outputs "[Traduit par la Rédaction]".
3.4. Insert a key word

Each key word is tagged separately; the punctuation is generated and cannot be edited.
Note that the final comma will be replaced with a period in layout, so there is no need to
add the punctuation at the end of the final key word.
To add a keyword, switch to "Tags On" view.
Put your cursor outside a <keyword> tag.
Go to Element Insertion list, select <keyword>, and insert.
Type the key word over "replacement text".
To move keywords around, use either "drag and drop" or "cut and paste" technique
for each <keyword> tag and its entire contents.
3.5. Insert an internal link

Internal links <intlink> are generated on export from Word for equation, figure, table,
table footnote, footnote, and reference citations. This element includes IDREF information
that matches the ID information of the target. In some cases, these links may need to be
added during editing (for example, equation citations in brackets or parentheses that are
not preceeded by the word "equation" or "eq." will not be automatically linked in the
premarking process, and must be manually linked in XMetaL).
Ensure you have the "Insert Element" palette open (View>Element list).
Select text to be the internal link (i.e., select reference citation or figure callout
within body of manuscript).
Find "intlink" in the "Insert Element" list (the elements are listed in alphabetical
order).
Double-click on "intlink" or select "intlink" and hit "Apply" to insert "intlink" tags
around selected text.
You may be prompted to enter the IDREFS for this internal link: Enter a unique
identifier (an ID code that has not been used as yet in the manuscript) that will match
the ID of the destination (for example, the IDREFs for the reference citation that was
selected above as an "intlink" and its reference in the reference list must match) (See

also sheet titled ID Syntax).
If you are not prompted to enter the IDREF number, be sure to enter the IDREF for each
"intlink" using the Attribute Inspector. The document will not be valid without a proper
IDREF for each intlink.
3.6. Callouts with multiple IDREFs (tables, figures, references)

The following information is true for all ID/IDREFs (i.e., table, figure, or reference
linking) EXCEPT numbered references. In order for automatic renumbering of numbered
references to work, only one IDref can be present at any time for one <intlink>:
Table, figure, or reference callouts may have multiple citations (i.e., "see Figs. 1, 3, and
5").
For the <intlinks> surrounding these multiple-citation table, figure, or reference callouts,
the IDREFs for each table, figure, or reference will be listed in the Attribute Inspector with
one space separation, as follows for the above example: "fig1 fig3 fig5".
The table, figure, or reference will still be placed immediately after the first citation, but
"double-clicking" the callout with the multiple citation will NOT transfer the cursor to the
table, figure, or reference caption, and double-clicking just inside the open <table>,
<figure>, or <reference> tag will transfer the cursor to the first SINGLE table, figure, or
reference callout, not necessarily the first table, figure, or reference citation within the text.
3.7. Insert footnote to text

Place cursor where the callout (footnote citation) should appear in the text.
Use "Insert Element" list to insert <footnote> tags.
Enter unique ID value that corresponds with the number of the actual footnote (i.e.,
fn10 will use "10" as the callout and footnote number) when prompted or in
"Attribute Inspector" if not prompted.
Count all possible footnotes (including ID box information - but do not include
affiliations, which do not have footnotes) up to the location of current footnote.
Use the location number as the unique ID number (i.e., if it is the 7th footnote in
the manuscript, the IDref will be "fn7", even if it's the first footnote to the text).
Type footnote text over "Replacement Text".
To insert a second callout (footnote citation) to the same footnote somewhere else in the
text:
Place cursor where the callout should appear.
Use "Insert Element" list to insert <footnote_refs> tags.
Enter same IDREF value as above (i.e., fn10) using "Attribute Inspector".
To insert more than one footnote callout at the same location (i.e., "2,3"):
Insert first footnote callout as above.
Place cursor either just inside the opening <footnote_refs> tag or just before the

closing </footnote_refs> tag.
Use "Insert Element" list to insert a <footnote_ref> tags.
Enter IDREF for new callout in "Attribute Inspector", thus linking it to appropriate
footnote (i.e., "fn3")
Layout will automatically insert the comma between the footnote callouts and they will
automatically be styled per Research Press style.
3.8. Insert Table of Contents for article

NOTE: The article ToC will be automatically generated from level 1 and level 2 headings,
per RP style. Thus, no text is entered between the <articletoc> tags, and the original ToC
text may be deleted.
Turn on "tags on" view.
Place cursor just after opening <body> tag (right after keywords or mots cles).
Select "articletoc" from Insert Element list.
Delete any ToC text in the manuscript (may be styled as a list).
3.9. Insert new heading or create heading from text in paragraph

NOTE: creating a new heading is not as simple as it sounds. A new "section" must also be
created, incorporating all the text that goes with the new heading and not leaving any text
"sectionless" -- i.e., the new section must include all text from the new heading down to the
closing tag of the previous section or to the start tag of the appropriate section. Below are
the instructions on how to create a new heading:
Add <para> with title of new section if not already present.
Select opening <para> tag at start of heading text, and continue highlighting (i.e.,
SHIFT + left mouse click) down each paragraph of the new section until the next
<section> or </section> tag is reached.
Insert <section> tags around highlighted text and tags using "Insert Element" palette.
NOTE: you will only be able to insert a "section" tag if no text is left sectionless - all text
from the heading down to the appropriate <section> or </section> tag must be
highlighted.
Place cursor in heading text (heading text tags should look like this:
<section><para>HEADING TEXT</para>).
Click on "change" button in "Insert Element" palette.
Select "title" from "Insert Element" palette. Heading tags should now read:
<section><title>HEADING TEXT</title>.
Don't forget to insert a unique IDREF for the new title in the Attribute Inspector. Title
IDREFs start with "t" followed by a unique number (i.e., IDREF: t1000).
Use indent/outdent buttons to select proper heading level (see instructions below).

3.10. Change heading level

WARNING: Changing heading levels will remove all tracked changes in that section.
Please adjust all heading levels prior to editing. After editing has begun, heading levels
must be changed manually in plain text (ask for help if required).
NOTE: Heading levels must be sequential ("nested"). For example, a heading 4 cannot
follow immediately after a heading 2. An error message will appear if the change in
heading levels would break the sequential heading rule.
To see heading level, view "context bar" at bottom left of screen; for example, "section /
section / section / title" indicates a level 3 heading.
Turn off track changes.
Place cursor within heading (inside <title> tags) to be changed.
Click

button to increase heading to a higher level (i.e., heading 2 to heading 1).

Click

button to decrease heading to a lower level (i.e., heading 2 to heading 3).

3.11. Insert list

Ensure formatting toolbar is displayed (View>Toolbars>Check formatting box).
Click on

for numbered or

for bulleted list.

Type content of list.
Hit enter/return to create next item in list.
3.12. Change list type

A numbered list is always displayed as "1." or "a." in XMetaL. If the attribute value for the
numbered list is changed (i.e., to parentheses "(1)"), the new list style will not be visible in
XMetaL but will print correctly.
Put cursor within text in a list (within a <listitem> tag).
Right-click to open menu.
Select list style as "1.", "(1)", "(a)", bulleted, or none.
3.13. Continue text from previous paragraph

Text following a list, an equation, or a block quote may be a continuation of a previous
paragraph, rather than the start of a new one.
IF text should continue from previous paragraph,
THEN
Place cursor right after opening <para> tag next to continued text (if it
exists).
Delete opening <para> tag to merge with previous paragraph.

3.14. Insert special characters

NOTE: the "guillemets" characters do not look correct in XMetaL, but will be displayed
correctly in 3B2 (layout).
Ensure "NRC Character" toolbar palette is visible by right clicking on the top gray
toolbar area and selecting "NRC Characters".
WARNING: do NOT select "Special Characters" or "Symbols" toolbars, as these will
not show properly in 3B2 (layout).
WARNING: do NOT place "nrc" entities (i.e., "&nrcinvdec;", "&nrccirf;") in the
abstract or title, as these entities may not be properly recognized by the aggregators.
Place cursor where you want to insert the character within the manuscript.
On the "NRC Character" toolbar, click the character to be inserted.
If character is not found on the "NRC Character" toolbar, use "Insert>Entity
reference" from the drop-down menu instead (make sure to select "Entity set: Rules
File" from the drop down menu at the bottom of the pop-up box for the full set of
allowed entities). (See Insert Entity List).
3.15. Insert combined character: creating gifs for the web (HTML)

There are no combined characters (i.e., V&dot;) in HTML. To have layout automatically
create a gif for a combined character, follow these instructions.
Select combined character using mouse (i.e, "V&dot;")
Insert <texttoimg> tag using "Insert Element" list
<texttoimg>V&dot;</texttoimg>
NOTE: currently there are no gifs allowed in the abstract/resume or author block in
HTML. Edit combined character out of these locations until further notice.
3.16. Insert radical symbol

There is no entity for a radical symbol. Instead, use the superscripted bullet.
Place cursor at desired location.
Using "Insert Element" list, insert <super></super> tags.
Insert &bull; entity between <super> tags:
<super>&bull;</super>
3.17. Stacking subscripts and superscripts

The <stack> tag can be used to stack superscripts over subscripts. Alternately, set up a
MathFlow equation for more complex stacking.
Place cursor at location in text where stacking will occur.
Using "Insert Element" tool, select <stack> tag.

Place text in <sub> and <super> tags, as follows:
<stack><sub>TEXT</sub><super>TEXT</super></stack>
Note: stacking from <stack> tag will not show in HTML, instead the superscript and
subscript will be staggered. The only way to show stacking in HTML is via a gif (equation).
3.18. Count words in document

Note: word count is approximate, owing to tagging in XML. A true word count can only be
achieved by counting words prior to export to XML.
Ensure NRC RP article toolbar is visible: View>Toolbars>Check NRC RP article.
Click button

in RP article toolbar.

3.19. Find and Replace Text (without tags)

Select text to be found.
Hit CTRL+F or select "Edit>Find and Replace".
Enter text in "Find" and "Replace" fields.
To limit search to text that is within a specific tag, select "Options>>", then select
the tag from the "Within element" drop-down list OR type the tag name into the
"Within element" window (include angle brackets <>).
Replace individually, or replace globally using "Replace All".
3.20. Find and Replace Elements

NOTE: It's not possible to replace every element with any other element; replacements that
are invalid will result in an error message.
CTRL+F or use the drop-down menu and select "Edit>Find and Replace".
Select Element tab.
Type in element name tag, including <>, or select element name from lists for "Find"
and "Replace" (NOTE: only the opening tag is needed; the closing tags will be
automatically replaced.
Replace individually, or replace globally by clicking on "Replace All".
3.21. Find and replace text with an entity

For example, find a hyphen and replace it with an n-dash.
A character inserted using shortcut keys or toolbars will be converted to the corresponding
entity when the file is saved. It is thus important to save the file before using "Find" to
search for any entity that was initially entered using the shortcut keys or toolbars (e.g.,
searching "&ndash;" instead of "–").
Save the manuscript.

Go to "Edit>Find and Replace".
Select "Text" tab and enter the character to be found (e.g., "-").
Select Options>>, then check the box for "Replace with entity".
Type entity name in "Replace with" field (e.g., "&ndash;") or use shortcut keys to
generate character and click "Find".
3.22. Find and Replace Wildcards

See intructions in PO instructions.
3.23. Find and Replace: Greek Entity Wrap Tool

Placing <italic> or <bold> tags around Greek characters will result in a 'slanted' or
'bolded' appearance for Greek characters located in the text of a manuscipt, for both the
layout pdf and on the web (HTML).
The "Greek entity wrap" tool (located on the toolbar) can help streamline this process.
Follow these instructions to use this tool:
Make sure the "RP Greek Entity Wrap" toolbar is visible (see "XMetaL views and
workspace setup" section above).
Click on the blue omega icon located on this toolbar. This will open up the Greek
Entity Wrap tool.
The box on the left shows all the Greek entities located within your manuscript. Use
the central buttons (arrow keys, "add lowercase", "add uppercase", or "add all") to
select individual or groups of Greek entities. These will be placed in the box on the
right.
Check one of the options at the bottom left of the Greek tool: "add bold", "add
italic", "add bold + italic", or "remove bold + italic". This will add or remove the
relevent tagging for all selected (in right box) non-math Greek entities within your
manuscript.
NOTE: all text-based Greek will be exported from Word as the "upright" or "roman"
character (&agr; etc.). All math-based Greek will be exported from Word as the "italic" or
"slanted" character (&alpha; etc.). To change the style of math-based (MathFlow) Greek,
please follow the instructions in the Math Instruction section of the binder.
3.24. Greek characters in title: Appearance in 3B2

Greek characters in the title of a manuscript may appear "light-faced". To make the
characters appear darker, follow these instructions:
Select Greek character in title.
Using "Insert Element" tool, select "Stroke" and click "Apply".
The Greek character should now be surrounded by an opening and a closing <stroke> tag.
These tags are read by 3B2 only and are ignored in XMetaL.
3.25. Tagging database numbers (CCDC, EC, GenBank)

Using the cursor, highlight only the digits that make up the database number (i.e., do
NOT highlight the word "GenBank", etc.).
Ensure these numerals are in the correct format for their respective database.
Double-click to select the "database" element from the "Insert Element" list. This
will put <database> tags around the numerals highlighted in the previous steps.
In the "Attribute Inspector", set the database "type" from the drop-down menu.
Currently, HTML does not link database numbers; however, tagging database numbers
now will ensure they will be linked when this functionality is added to HTML in the future.
3.26. "Associated Papers" and "Referring papers" elements (i.e., erratum, supplementary data,
comments, etc.)

See also section on "Front matter and other paper types" below.
"Associated papers": This element is used within the original manuscript for additions,
comments, commentary, companion, corrigendum, discussion, erratum, letter, reply,
retraction, series-paper, and supplementary-data.
IF the "associated paper" is for supplementary data,
THEN follow these instructions for each supplementary file:
Place cursor just inside closing </admin> tag.
Select "Assocpapers" from "Insert Element" list and insert.
Place cursor between "Assocpapers" tags.
Select "Supplementary-data" from "insert element" list and insert.
Type in filename between tags (the filename of the supplementary data is
the RP manuscript number (i.e., v05-123) followed by an alphabetical
character (only if more than one supplementary file for the ms), or two
letters if more than 26 files (v05-123.xxx, v05-123a.xxx, or v05-123aa.
xxx).
Insert description of supplementary data between "short-description" tags
for each file.
Place cursor between "short-description" tags and select language
(English or French) in "Attribute Inspector" window.
Insert a "short-description" in the other language as well, place cursor just
inside closing </file> tag and select "short-description" from "Insert
Element" list. As above, select language (English or French) in the
"Attribute Inspector" window for each description. (NOTE: if your
journal does not publish the translated text on the web, insert the
original short description text into the second set of tags. For example,
the "short-description" text "Crystallographic figures" may be
inserted into both the English- and French-attributed tags.)
IF your file has more than one supplementary data file:
THEN
Place cursor after closing </file> tag.
Insert new <file> tags using "Insert Element".
Insert text for new "filename" and "short description" between relevent

tags.
Repeat for each supplementary data file.
Send the DUD e-file and the copywrite hardcopy pages to the Publication Clerk.
Send email to Web Technician letting them know the manuscript number and web
publication date of the file with supplementary data.
Indicate supplementary data on the white sheet on top of folder
Name actual supplementary data file in "Original" folder with the filename entered
in the XML with the addition. of "suppl" as a suffix (e.g., v05-123suppl.xxx or v05123asuppl.xxx).
IF the "associated paper" is NOT supplementary data (i.e., an erratum, etc.),
THEN follow these instructions:
Place cursor just inside closing </admin> tag.
Select "Assocpapers" from "Insert Element" list and insert.
Place cursor between "Assocpapers" tags.
Select associated paper type (i.e., corrigendum, etc.) from "insert element"
list and insert.
Type manuscript number between <msno> tags.
Type citation information into appropriate tags (journal, volume, issue,
start page, end page).
"Referring-paper": This element is used within the "associated paper" (i.e., erratum or
reply) to link it back to the original manuscript.
Place cursor just inside closing </admin> tag.
Select "Assocpapers" from "Insert Element" list and insert.
Place cursor between "Assocpapers" tags.
Select "referring-paper" from "Insert Element" list and insert.
Type manuscript number between <msno> tags.
Type citation information into appropriate tags (journal, volume, issue, start page,
end page).
Repeat if more than one "referring paper" (for example, for series of "comments"
and "replies".
NOTE: "Discussion" in the "articletype" attribute field refers to a set made up of comment
and reply; in contrast, the "articletype" "Comment" refers to a comment without a reply.
4. References
4.1. Edit references

To insert a new journal reference, click the "Insert Journal Reference" button in the
toolbar.
Journal references with the eXtyles comment "Cannot find a title to match the journal
XXX" may indicate an incorrectly spelled or abbreviated journal name. This comment was
generated when the references were checked against a list of journal names and
abbreviations ("Advanced Processes>Bibliographic references" in eXtyles).

Journal references with the eXtyles PubMed comment, i.e., "Medline indexes "Phycologia"
but cannot find a listing for the reference "Bird, Rice, Murphy, Ragan, 1992b", may
indicate an error within the reference (i.e., author's name spelled incorrectly, year
incorrect, etc.).
The tag "<other-ref>" indicates a reference that could not be classified in the eXtyles
system OR a reference-footnote in CJC:
Check the reference to ensure all punctuation, etc., is correct.
Change the tag if applicable by placing the cursor inside the <other-ref> tag, going to
"Insert Element" palette and clicking the "Change" button at the bottom. Select the type
of reference from the element list and insert.
If the reference is a journal, click the "insert journal reference" button in the toolbar
and cut-and-paste individual components of the reference into the journal tags, then
delete the empty <other-ref> tags.
If the reference is a CJC footnote, follow instructions below for Numbered references:
CJC footnotes in reference section.
In eXtyles, the following items are not automated and will therefore need to be done
manually by the EA or PO:
Insertion of semicolon between citations in a list of references in the text,
Alphabetical/chronological ordering of references in the reference list.
Sometimes a reference will be exported from Word with a hard return. This will appear as
two separate references in the XML. These references will need to be joined to appear
properly in print.
Turn on Tags On view.
Cut the text (see section "Cut, copy, and paste") from the second half of the split
reference (do not include the tags when cutting the text).
Paste text within the tags of the first half of the split reference (e.g., within <book>
or <conf-paper>).
Delete the now empty <ref-group> tags and associated nested tags from the second
half of the split reference (click on the end tag </ref-group> to select it and its nested
tags and hit delete).
Sometimes journal references include the year only as the volume number; in this case the
number should be lightface, not bold. The solution is to change the tagging around the
volume number to allow the lightface font.
Using the Insert Element List, insert <ref-issue></ref-issue> tags beside <volume>
tags.
Cut and paste volume number into <ref-issue> tags.
Delete empty <volume> tags.
4.2. Reference linking to databases (PubMed, CrossRef)

A feature of the XML system is the ability to link references within the manuscript to their
location in several databases. This feature allows the end-user to access the text of any
manuscript within the reference section with a click of the mouse.
Most often, this linking is accomplished in eXtyles. However, there are several cases

wherein a PO must manually link a reference to one or more databases. These cases
include:
Corrections made to a reference that hadn't previously been linked (see section below
titled "Comments in reference section from eXtyles");
Incorrect parsing of journal title in eXtyles;
New reference inserted following author alterations; etc.
To link the reference to one or more databases, follow the instructions below:
Go to database citation search website (see links below).
Copy and paste all or part of the reference information.
Ensure all information matches database.
Insert relevent element tags (<PMID> for PubMed, <doi> for CrossRef) just inside
the closing </ref-journal> tag.
Copy ID number (PMID or DOI) from website and paste it into relevent element
tags.
PubMed single citation matcher: http://www.ncbi.nlm.nih.gov/entrez/query/static/citmatch.
html
CrossRef: http://www.crossref.org/02publishers/37guest_query.html
4.3. Comments in reference section from eXtyles

Remember: queries are automatically numbered in the order they appear in the text.
eXtyles will automatically insert comments in the reference section that may alert the PO to
grammatical errors, spelling errors, or style errors. Certain comments may also indicate a
failure to link to PubMed or Crossref or other databases. Below are a few of the common
comments and how to correct them.
IF the comment is similar to the following:
"The reference "Harlan, 1942" is not cited in the text. Please add an in-text
citation or delete the reference."
THEN :
Search the text for the reference; the authors' name may have been
incorrectly spelled or the year may be incorrectly cited.
If citation found, correct citation and insert "intlink" to link citation with
reference.
If there is no similar reference in the text, leave the comment for the
author.
IF the comment is similar to the following:
"Cannot find a title to match the journal "New Zealand J. Bot" (in reference
"Forde and Edgar, 1995")."
THEN :
Check the spelling of the journal title and find its correct abbreviation
(BIOSYS, CASSI, etc.).
If the spelling was initially correct, email the COPS team to request that
this journal title be added to the list of correct journal titles so that this

warning does not occur again.
IF the comment is similar to the following:
"Medline indexes "Darwiniana" but cannot find a listing for the reference
"Gutierrez, Pensiero, 1998". Please check the reference for accuracy." (This query
indicates that there may be an error in one or more parts of the reference, i.e.,
incorrect author name spelling, incorrect date, incorrect volume number, incorrect
page number, etc.)
THEN :
Search Medline (PubMed single citation matcher: http://www.ncbi.nlm.
nih.gov/entrez/query/static/citmatch.html) for this manuscript.
Make any necessary changes.
Insert the correct PMID in the reference.
4.4. Numbered references: General Instructions.

NOTE: An eXtyles macro changes references that are submitted as (1(a)) or [1(a)] to
(1a) and [1a], respectively (removes extra set of parentheses). Please contact the XML
team if you notice any errors connected to this macro.
4.5. Numbered references: Automatic renumbering of references

Each time numbered reference manuscripts are sent to layout, they will be automatically
renumbered, Please follow these instructions to ensure that automatic renumbering
proceeds smoothly.
Ensure reference list is in correct order (this will be renumbered first, and the new
numbers placed back into the text at their relevent citations).
Ensure correct IDref at each citation:
Numbered references without alphabetical parts will make use of the IDref for
<ref-group> that starts with the letters "rg", followed by a unique number.
Numbered references in alphabetical parts (i.e., 1a, 3c) will make use of the IDref
for <reference> that starts with the letters "ref", followed by a unique number.
4.6. Numbered references: CJC footnotes in reference section

Footnotes for CJC should have been inserted into the reference list by the author or by the
premarker (at the end of the reference list).
Footnotes have different properties than references. To access all possible elements for a
footnote that is located in the reference list, follow the instructions below.
Place your cursor between the open and close <other-ref> tags.
In the "Insert Element" list, select the "Change" radio button at the bottom.
Select <ref_CJC-fn> from the "Insert Element" list.
In the "Insert Element" list, select the "Insert" radio button at the bottom.
The full list of footnote element options will now appear in the "Insert Element" list.

Note: for footnotes and their citations to be correctly numbered upon automatic
renumbering, ensure that they are in the correct sequential order within the reference list.
4.7. Numbered references: Appendix reference lists.

A manuscript containing appendices will have hyphens in the IDrefs, so as to differentiate
between body and appendix (i.e., "ref-1-1" for body, "ref-2-1" for appendix).
5. Edit author information
5.1. General

NOTE: layout (3B2) will automatically place commas between authors' names and a
period following the final author's name.
IF the final author's name includes, for example, a suffix with a period (Jr.),
THEN leave the period OFF the suffix (Jr), or else the final layed-out
version will contain two periods following the final author's name and suffix
(Jr..), one inserted and one generated.
5.2. Author order (sequence tags)

<Sequence> tags appear right after opening <author> tags. The order for each author's
name in the author list, in the ToC, in the abstract, and for aggregators is determined by
the number between the set of <sequence> tags.
To change the order of author, follow these instructions:
Manually reorder author names in XMetaL by clicking the <author> tags and
dragging them and all the information contained therein (or cutting/pasting) to the
correct location.
Reorder numbers between <sequence> tags to reflect new order of authors.
5.3. Insert author name

Place cursor where author name is to be inserted (if a first author, place cursor
immediately after openning <authors> tag; if subsequent author, place cursor
immediately after closing <author> tag of previous author).
Using "Insert Element" palette, insert <author> tags.
Insert <fname>, <mname>, and other applicable tags using "Insert Element" palette.
Type name over replacement text.
5.4. Papers with only one author

Follow these instructions to ensure author information conforms to RP standards in the
case of a manuscript with only a single author:
Select e-mail information from <Contact> field.
Copy e-mail address (don't include the <extlink> tag).

Place cursor just inside closing </affiliation> tag OR just inside closing </
presaddress> tag (see "optional" grey box below), whichever is more relevent.
Paste e-mail information in parentheses per example below.
Example: "<affiliation>Laboratory Instructor and Coordinator, Anatomy and
Physiology, McMaster University, Hamilton, ON, Canada (e-mail: carla.
geurts@gmail.com).</affiliation> "
NOTE: Do not delete the e-mail address text within <contact> tags and do not remove the
attribute "corresponding = yes" for <author>.
IF there is a present address and it is that address that the email corresponds to
THEN you can include the text for the email in the Present address as per
RP style.

5.5. Change corresponding author

Place cursor just inside open or close <author> tags.
In the "Attribute Inspector", change "corresponding" to "yes" or "no".
Ensure contact information is present for corresponding author (see below).
NOTE: it is NOT necessary to delete contact information for non-corresponding authors,
as this information is now retained in the XML system.
5.6. Insert contact information

Place cursor just after closing </aname> tag.
Using "Insert Element", insert <contact> tags.
Insert <extlink> (for email address), <fax>, and (or) <phone> tags using "Insert
Element" palette.
Type in contact information in correct tag.
For email addresses, you need to also fill in the "protocol" and "location" attributes. The
protocol should be "email", and the location should be the email address.
5.7. Add footnote to author

Footnotes to authors can now be properly exported from Word. Or, follow the instructions
below to insert a footnote to author after export:
Follow these instructions to insert footnotes to authors:
At first author for whom footnote is relevent, place cursor just after the closing </
aname> tag.
Insert <footnote> tags using "Insert Element" list.
Enter unique IDref (fnX where "X" is a unique number) when prompted or in

"Attribute Inspector".
Insert footnote text between <footnote> tags.
Place cursor between closing </footnote> tag and closing </author> tag.
In the "Attribute Inspector", enter the footnote IDref beside the "fnref" attribute.
At second and subsequent authors for whom same footnote is relevent, place cursor
just before closing </author> tag.
In the "Attribute Inspector", enter the same footnote IDref beside the "fnref"
attribute, as above.
Below is an example of how a footnote linked to two authors should appear in XMetaL:
<author affref="aff1" fnref="fn1"><sequence>1</sequence><fname>Barbara</
fname><lname>De Nardi</lname><aname>B. De Nardi</aname><!-- 1 --><!-- 5 -><footnote>These authors contributed equally to this work.</footnote></
author>
<author affref="aff1" fnref="fn1"><sequence>2</sequence><fname>Rene</
fname><lname>Dreos</lname><aname>R. Dreos</aname><!-- 1 --><!-- 5 --></
author>
5.8. Change author affiliations

In 3B2, authors and affiliations will layed out in RP style. In the HTML, author affiliations
will be linked to the authors names by the ID/IDREF values. However, they will be ordered
based on the order of the <affiliation> in the document. This might result in the footnotes
to authors names being out of order, e.g.,

Place cursor just inside open or close <author> tags.
In the "Attribute Inspector", type proper affiliation ID number beside "affref"
attribute.
5.9. Add author affiliation/present address etc.

Place cursor just before closing </authors> tag.
Using "Insert Element" list, insert <presaddress> or <affiliation> tags.
Insert unique IDREF in "Attribute Inspector" (either "afid" or "paid").
Place cursor inside appropriate opening <author> tag.
In "Attribute Inspector", fill in IDREFs under "affref" (for affilations) or "paref" (for
present address).
5.10. Edit ID box abbreviation

Place cursor inside <aname> tags.
Manually edit author abbreviation for ID box.
5.11. Running heads

Running heads are automatically created by layout. Occasionally, you may need to alter
the content of running heads; for example, the following will need to have altered running
head content:
Sequence papers will need sequence number added.
Author names with "Jr." will need comma added.
To insert alternate text for the running head, follow these steps:
Place cursor just before closing </admin> tag in "Administrative information" box at
top of manuscript.
Insert <run-head> tags using "Insert Element" list.
Type alternate text in <run-head> tags.
6. Edit Math
6.1. Set equation size

Note: Primes may not be exported to XMetaL correctly, depending on how the author did
them. Check all spacing in the equation and delete any unecessary whitespace.
Right click on the equation.
Select "column", "1page", or "foldout" based on how the equation should be
displayed.
6.2. Set equation numbering

All displayed equations need to have <no></no> tags, even if they are empty, and even if
the equation is meant to have no number in print. This is necessary for 3B2 to lay them out.
IF there is no number (<no>) tag before the displayed equation,
THEN place cursor just inside opening <equation> tag and insert <no>
element tags using "Insert Element" palette.
There are four types of equation numbering: "auto" (regular sequential), "auto2start and
auto2" (equation in parts), "manual" (any numbering other then auto or auto2), and
"none" for no numbering. Manual means that 3B2 will output whatever is contained in the
<no> tag as the equation number.
IF the displayed equations should be numbered sequentially as they appear in the
manuscript,
THEN do not alter the default ("auto") numbering.
IF there are a set of equations in parts requiring numbering, i.e., 9a, 9b, 9c, etc.,
THEN

Place cursor inside opening <equation> tag for first section of an equation
in parts (i.e., 9a).
Right click and select "auto2start".
Place cursor inside opening <equation> tag for second section of an
equation in parts (i.e., 9b).
Right click and select "auto2".
Continue setting attribute to "auto2" until a new equation is reached.
For next equation, select "auto2start" for the start of a new equation in
parts, or select "auto", "manual", or "none" for other types of equations.
IF the equation numbering is much more complex (i.e., equations numbered by
section or with other prefix/suffix information),
THEN Right click on each equation and select "manual".
To insert a <no> tag if one is not there already, switch to Tags On view, place cursor
just after the opening <equation> tag.
Select "no" from the Element insertion list.
IF the equation should not be numbered,
THEN right-click on the equation and select "none".
6.3. Fix MATHTYPE error 14

This error will be identified on export by eXtyles when an author has incorrectly structured
an equation. It can be fixed in MathFlow.
Change view to "Tags On View" by using button in bottom task bar or going to
"View>Tags On".
Go to "Edit>Find and Replace" or use CTRL+F.
Search for error by typing "MATHTYPE" into the Find field; this will take you to
the comment that eXtyles inserted for Mathtype error 14.
Open the equation associated with the Mathtype error in MathFlow by double
clicking on it.
Compare the equation to the author's original and fix any discrepancies.
6.4. Insert new equation

Put cursor where you want to insert an equation (note: you cannot insert an equation
outside of tags; for example, you cannot insert an equation after a closing </para>
tag and before the following opening <para> tag).
In the NRC RP toolbar, click
equation.

for a displayed equation or

for an inline

A form may pop up asking for an ID value. Add a unique ID value to the new
equations (this value is used only to link within the manuscript; it will not be used in
printing output; i.e., the equation number is set separately (see below).) (See also

sheet titled "ID Syntax").
If you are not prompted to enter the IDREF number, be sure to enter the IDREF for each
equation using the Attribute Inspector. The document will not be valid without a proper
IDREF for each equation.
7. Edit Tables
7.1. Captions

Include period in <no> tag.
7.2. Change data alignment

NOTE: Data alignment will not always display correctly in XMetaL (e.g., when the data is
decimal aligned and there is more than one decimal in the cell), but it should be layed out
correctly in 3B2.
Do not select an entire row or column when aligning, as the tag will not be correctly
placed. All alignment except for character alignment should have been done at the eXtyles
stage.
To decimal align a column that contains both implied decimals and letters (i.e., 20a,
19.34b, 32.12), use the "Invisible Decimal" character at each implied decimal (see below
for further instructions).
If you must align part of a table in XMetaL, select a section of a row or column, and align
as follows:
Select appropriate cells in the table.
Right click and select "Table properties" OR Select button
toolbar.

from the Table

Select the "cell" or "selection" tab.
Under "Horizontal alignment", indicate left, centre, right, or character alignment.
Under "Vertical alignment" indicate top or bottom.
In character alignment ("Char"), the data can be aligned by any character. The
default alignment character is a decimal. To change this alignment, type in the new
alignment character in the window beside "Char".
For alignment characters that are not keyboard characters, copy the character before
editing table properties so that you can paste the character in the "Char" field.
7.3. Using the "Invisible Decimal"

"Invisible Decimal" is used when decimal aligning columns that contain both implied
decimals and other letters or characters (i.e., 20a, 23, 17.34b, 9.2c).
Layout staff can also be asked to insert the invisible decimal, if it is not spotted prior to
layout.
Place cursor at first implied decimal.

Insert invisible decimal using either "&nrcinvdec;", icon on toolbar, or "CTRL+D"
shortcut.
Repeat for every implied decimal in column.
7.4. Change row alignment of headers

If the row alignment of headers must be changed, instruct layout staff.
7.5. Indent within table

Table cell content that "wraps" will not "look" correctly indented in XMetaL, but will be
correct in 3B2 (layout).
NOTE: All indent levels will "look" the same in XMetaL but will be correct in 3B2 (layout).
Note: An indent level of "1" is RP styles first indent level.
Select text to be indented.
In "Insert Element" list, double-click or select & enter "indent".
Set indent "level" to 1, 2, 3, 4, or 5 in "Attribute Inspector".
NOTE: if you place footnote citation <intlink> tags within the <indent> tags (i.e.,
<indent><intlink>*</intlink></indent>), the generated text "*" will disappear. This will
not affect layout. Alternately, the footnote citation <intlink> may be placed outside of the
<indent> tags without affecting layout (i.e., <indent></indent><intlink>*</intlink>).
7.6. Move or delete columns or rows

To move or delete a regular column or row, use "delete" or "move" buttons in table
toolbar.
Columns or rows cannot be moved or deleted if they do not span the height or width of the
entire table (i.e., if cells have been merged to span 2 or more columns or rows). To move or
delete a column or row that breaks part-way down the table, first elongate so that it spans
entire table height/width:
Place cursor in table at merged cell closest to break in column or table.
Click "Split Cell" buttons in Table toolbar to split cell into 2 columns or 2 rows.
Continue above steps until column spans entire height of table or row spans entire
width of table.
Use "delete" or "move" buttons in Table toolbar to manipulate full row or column.
7.7. Size tables to approximately final size

Do not adjust column widths in XMetaL to fine tune layout once the file has been sent to
layout - this will interfere with the layout program.
Tables that are not "whole" (i.e., header in a separate table) will not layout properly in
3B2. While sizing tables, ensure table is whole and complete before sending to layout;

incomplete tables may have to be sent back to eXtyles.
NOTE: Tables with various levels of "indenting" will need extra space, as the indent levels
are not accurately represented in XMetaL (see also section on table indenting).
Switch to "Normal View" ("View">"Normal").
Ensure Table toolbar is visible: View>Toolbar>Check Table box.
Adjust column widths, starting with the left-most column and working left-to-right,
to a "best guess" based on the fit of the cell contents.
in Table toolbar; this will indicate whether the table will
Click table size button
be "column", "page wide", broadside", or "multi-page" wide.
Adjust column widths if necessary to make table closer to final desired size.
7.8. Table footnotes

NOTE: Table footnote symbols will be automatically placed in proper order by layout.
Thus it is not necessary to place any text between the <no> tags or at the "intlink" - all
such text will be ignored by 3B2.
NOTE: footnotes at bottom of table must be in proper RP style order; only the symbol
order will be automated by 3B2 (layout), as described above.
To change footnote numbering style (alphabetical or symbol), place cursor inside the start
tag <tablefn> and select the style choice from the drop-down menu beside "refmark" in the
"Attribute Inspector".
IF there are no footnotes in the table already,
THEN use the toolbar button to insert the footnote, as follows:
Place cursor in the table.
button in the Table toolbar (this will insert an empty footnote with
Click the
empty <no> and <fn> tags).
IF there is already a footnote in the table,
THEN insert another <tablefn> element, as follows:
Put cursor after closing </tablefn> tag.
Insert <tablefn> element from the "Insert Element" palette list.
Enter unique identifier (IDREF) when prompted (See also sheet titled "ID Syntax").
Enter footnote text between <fn> tags; there is no need to enter any text between the
<no> tags (see above instructions).
Set the style of EACH footnote to "symbol" or "letter" by placing the cursor just
inside the <tablefn> start tag, going to "Attribute Inspector", and selecting "letter" or
"symbol" from the drop-down list beside the "refmark" attribute. This process must

be repeated for each footnote to each table.
Below are instructions to link the footnote to text within the table; see also section "Insert
an Internal Link".
Put cursor beside text in cell to which footnote will be linked.
From "insert element", select "intlink".
Enter the same IDREF for <intlink> as for the footnote to which it will be linked.
IF there is more than one adjacent footnote link in the same cell,
THEN follow these instructions to place a comma between the adjacent
footnote symbols/letters:
Place cursor just after first closing </intlink> tag in cell.
Insert a set of <super> tags using the "Insert Element" palette list.
Type a comma between the <super> tags (i.e., <super>,</super>).
Insert the second <intlink> tags using "Insert Element" palette.
Enter the same IDREF for <intlink> as for footnote to which it will be linked.
NOTE: a "<tfoot> " validation error indicates that there is an empty <tfoot> tag. This
occurs when ALL the table footnotes are removed.
IF you remove all table footnotes,
THEN follow these instructions to avoid validation errors:
Delete empty row at bottom of table.
Place cursor at the very end of the table header.
Switch to "Plain text" view.
Delete the empty <tfoot> tags (e.g., "<tfoot></tfoot>").
Switch back to "Tags-on" or "Normal" view.

7.9. Insert note

Place cursor outside table and just inside closing </table> tag.
Double-click to select <note> from "Insert Element".
Type text of note within <note> tags.
7.10. Table head

NOTE: do NOT insert non-breaking spaces (&nbsp;) within any table header. Nonbreaking spaces in table headers will cause problems on layout. Please instruct layout

manually where to break table headers, if necessary.
To insert a row in the header of a table, make sure cursor is within the <thead> tags (i.e.,
cursor must be at the end of an existing header and NOT in the first row of the table body).
The context path at the bottom of the screen will indicate whether the cursor is within the
<thead> or <tbody> tags.
Put cursor in the last current row of the header.
Click the toolbar button to insert a row below or above.
IF you have a table in parts that requires a header in the middle of the table that was
not correctly styled during premarking,
THEN you must send the ms back to your EA with instructions on how to
style the table, then cut & paste the exported, corrected table into your
document.
IF you wish to create a header at the top of the table and there is no header row,
THEN you must do this in plain text view, as follows:
Position cursor just inside the first cell (at start of table).
Switch to "Plain Text" View.
Insert a line just before the <tbody> tag, and on this line type "<thead>", then hit
"enter/return", and type </thead> on the following line.
Select everything between the nearest opening <row> tag and closing </row> tag,
including the <row> tags.
Copy and paste the row between the opening <thead> and closing </thead> tags.
Your plain text view should now look something like this:
<thead>
<row>
(all the stuff in the row, i.e., <entry...)
</row>
</thead>
<tbody>
IMPORTANT: working in plain text view can easily invalidate your entire document. If you
are not comfortable working in plain text view, send the ms back to your EA with
instructions to style the headers, then cut & paste the new table back into your document.
Then switch back to Normal view and edit the content of the header row as
necessary
7.11. Table rules

Tables should only have rules that are non-standard (i.e., boxes around a group of data),
because 3B2 (layout) will generate all of the standard rules according to RP style. Tables
should have been exported from Word without rules, but if this is not the case, then delete
all other table rules as follows:

Manually select section.
Go to Table properties

.

Ensure you are in the Selection tab.
Set "colsep" and "rowsep" to "0".
Click OK.
7.12. Transpose table

Tables cannot be easily transposed in XMetaL. Transposing a table must be done in
WORD and EXCEL and then re-exported to XML. It is possible to do this yourself or else
send the table back to your EA.
7.13. Table in parts

Tables in parts must be set up as such in Word. If the table has not been set up properly,
please send back to EA with instructions to re-export as a table in parts (or ask COPS
support to help you fix it in XMetaL).
Do not leave extra empty columns in a table in parts. The two parts of the table do not need
to have the same number of columns, nor do the columns have to "line up" (i.e., be the
same width on top and bottom).
The "Table Size" icon on the table toolbar will not work for a table in parts. Visually
estimate the correct size for the table.
Decimal alignment does not work on second and subsequent parts of the table. This is a
temporary problem, and it is best to avoid decimal alignment entirely in a table in parts,
for consistency within the table. This problem currently (19/04/07) occurs both in XMetaL
and on layout (3B2) and will be corrected in both locations in future.
7.14. Create new table

There are various ways to create a new table, some more problematic than others.
1. The best way to create a new table: export from Word
Have the EA fix the table in Word and export.
Copy & paste the <tgroup> tags containing the table into your document.
2. The second best way: copy and paste an existing table.
Find an existing table in your document (or another XML document).
Copy & paste the entire table into the new location.
Insert and (or) delete rows and columns as needed (ensure there are enough
<thead> and <tbody> rows for your new table).
Delete old text and insert correct text in each cell.
3. Problematic: use "Insert table" icon in the "Table" toolbar
This method of creating a new table is problematic because the table that is inserted will
have completely incorrect (for RP) default settings (borders, alignment, etc.). Thus, every
setting must be carefully changed. Remember that selecting an entire row, column, or table

and then attempting to change "Table properties" settings will cause XMetaL to crash.
Place cursor at location of new table.
Click "Insert table" icon from "Table" toolbar.
Carefully remove all borders (do NOT select an entire row, column, or table!) by
selecting "0" for "Column separator" and "Row separator" in the "Table
properties" box.
Carefully remove outside border by clicking in table (without selecting any cells),
and selecting "None" for "Frame", under the "Table" tab in "Table properties"
box.
Carefully (do NOT select entire row, column, or table!) set all alignment (upper
right, lower right, character) for table.
Column by column, set the column width to "45" (or larger) and "points" (rather
than "*proportional") in "Table properties".
Insert new text into table.
8. Edit taxonomy
8.1. Tagging taxonomic names

There are several elements for tagging taxonomic names: genus, species, bv, form, fsp, pv,
race, sect, series, species, subgenus, subsect, subseries, subsp, subvar, var. Each of these
items only needs to be tagged once in the abstract and once in the body of the article. For
example, for each genus and species name, you only need to tag them as such once; each
subsequent instance should be tagged "italic" (this is how they will export from eXtyles).
A <taxmajorhead> is a Taxonomy head 1 (see Blackbook) and a <taxminorhead> is a
Taxonomy head 2.
XMetaL and 3B2 will display taxonomically tagged items as italic automatically, so there
is no need to tag taxonomic items twice; for example, for the taxonomic names that are
tagged in the abstract, there is no need for an italic tag as well.
Binomes should be tagged as "species"; "genus" is only used when it's just the genus on its
own.
NOTE: delete the colon from taxminorheads, as these colons will be generated in layout
(3B2).
NOTE: Do not add a <smallcap> tag to <taxminorhead> --- this will be output as
"smallcap" in 3B2 automatically (layout).
NOTE: <taxminorhead> MUST be in all lowercase letters (RP style does NOT initial cap
these small capped headings).
Whether to tag every species in the manuscript once will be up to the discretion of the MEs
and POs.
8.2. Edit taxonomy synonym

Put cursor where the taxonomy synonym is to be inserted OR select text around
which tags are to be inserted.
Double-click on <taxsynonym> in the "Insert Element" list or select and hit "Apply"
to insert.

A form will pop up asking you to insert the indent level: Select 1 if it's a taxonomic
(facultative) synonym (=) or 2 if it's a nomenclature (obligate) synonym (≡).
IF the symbol (= or ≡) should be visible in the printed version,
THEN that symbol (= or ≡) must be typed in manually.
8.3. Edit taxonomy hierarchy item

If a taxonomy hierarchy item was structured as such in the Word file, then it will export
properly. If not, you will need to insert the elements for the taxonomy hierarchy and cut
and paste the text into them.
Put cursor where the taxonomy hierarchy item is to be inserted.
Insert <taxhierarchy> from the "Insert Element" list (this will insert one
<hierarchyitem> and one <taxa> tag).
IF the hierarchy is to be displayed with rank,
THEN insert a rank element for each <taxa>.
Switch to Tags On mode.
Put cursor before <taxa>.
Insert <rank> from "Element insertion" list.
IF there is no rank in the taxonomy hierarchy,
THEN set <taxa> indent level by putting your cursor in the <taxa> and
selecting the indent level from the drop-down list in the "Attribute
inspector".
Cut and paste content into these tags as appropriate (see section "Copying, cutting,
and pasting" for more information).
8.4. Edit taxonomy key

Taxonomy keys should be tagged correctly if they were styled correctly in Word. See
example taxonomy key with correct tagging. See marked up layout example (in Job Aids
section of binder) for element identification.
9. Manipulate graphics
9.1. Captions

Include period in number tags <no>, but no space.
9.2. Captions for figures on more than one page

If a figure is larger than one page, there will be separate graphics files for each page of the
figure. Therefore, separate figure captions must be created for each graphics file, as
outlined below.

Place cursor just after closing </figure> tag.
Insert <figure> tags using "Insert Element" list.
Enter unique ID value for figure in the pop-up menu when prompted (it is possible to
use alphanumberic ID values (i.e., fig5a) to denote figure parts appearing on separate
pages).
Enter "Filename", "Position", and "Caption Location" of graphics file if known into
the pop-up menu when prompted, otherwise just click "OK" and enter these
attributes in the "Attribute Inspector" at a later time.
Place cursor between new, empty opening <figure> tag and opening <graphics> tag.
Insert <caption> tags using the "Insert Element" list.
Insert <no> tags inside using the "Insert Element" list.
Cursor should now appear at replacement text between new opening and closing
<no> tags.
Tags should look like this: <figure><caption><no>CURSOR</no></
caption><graphic></graphic></figure>.
Type figure number, i.e., "Fig. X", following RP style used in blackbook.
Place cursor between closing </no> tag and closing </caption> tag.
Insert a <title> element.
Enter unique ID value for title (i.e., t100).
Type in "continued." or "concluded.", per RP blackbook style.
The unique ID value for each separate figure file MUST be linked within the text. The
instructions for linking the multiple files for a figure that runs on to more than one page
are outlined below.
Find the original figure citation within the text (it should be surrounded by "intlink"
tags, i.e., <intlink>Figure 5</intlink>).
Place cursor between <intlink> tags.
In the "Attribute Inspector", next to the "IDREF" attribute, enter all of the "unique
ID values" that you created for the figure files (as many as there are files for the
figure), with only spaces separating them (i.e., "fig1x fig1y fig1z" for figure that
runs on to three pages).
The continuing and/or concluding graphic must now be inserted. See section "Insert
graphic" for further instructions.
9.3. Math in Figure captions: Appearance in 3B2

Math placed in figure captions may also appear "light-faced". To make the characters
appear darker, follow these instructions:

Select entire equation.
Using "Insert Element" tool, select "Stroke" and click "Apply".
The equation should now be surrounded by an opening and a closing <stroke> tag. These
tags are read by 3B2 only and are ignored in XMetaL.
9.4. Insert graphic

NOTE: the tags around a figure and its caption should be nested as follows:
<figure><caption><no></no><title></title></caption><graphic></graphic></
figure>
When XMetaL opens, it automatically tries to "populate" each graphics "tag" with the
corresponding RP graphics file, based on the figure number in the manuscript. It will
produce an error message if this is not successful.
Ensure all graphics "tags" are "populated" before sending the file to layout by opening the
XML file once the graphics have been completed (i.e., when the graphics have been edited,
are in the proper manuscript folder, and in .eps or .tif format with RP naming convention).
In general, if the RP graphics files have been properly named, XMetaL will be able to
match the figure number in the manuscript with the proper RP graphics file. If the figure
has not been named properly, if the figure citation lists a range (e.g., Figs. 20–27), or if the
figure is unusually numbered in the caption, the RP graphic may have to be inserted
manually, as follows:
Only .tif or .eps files are valid; graphics will convert all files to the .tif or .eps format.
However, .eps files are not viewable in XMetaL.
IMPORTANT! Every graphics tag MUST be populated (i.e., matched with a .tif or .eps
file) before being sent to layout. Therefore, if figures arrive after you've finished editing
and have closed XMetaL, you MUST re-open XMetaL, ensure all figure files have been
inserted, and then perform one last "save" with every graphics tag populated before
sending the file on to layout.
IF a file was not matched automatically,
THEN go to that figure in the manuscript,
Switch to Tags On view.
Put your cursor after the <graphics> tag.
In the "Attribute Inspector", place cursor in the blank cell beside "fileref" and type
the name of the RP graphics file (e.g., x03-230f1.eps) into this blank field (graphics
must be in SAME folder as the manuscript - do NOT type in a filepath).
Here is another way to manually insert a filename into a graphic tag:
Go to "View>Resource Manager".
Navigate the top window to the folder on the I: drive where the graphics for the
manuscript are located (this must be the SAME folder location as the manuscript).
Drag and drop the RP graphics file from the Resource Manager to the appropriate

<graphic> tag in the XML file.
IF you are replacing an existing figure in the manuscript with a new figure,
THEN you will have to reply to the prompt "Replace existing graphic?".
IMPORTANT! If you have sent the file to graphics for changes, and they have changed the
format from .tif to .eps but have not deleted the "old" file, you MUST ensure that the
correct file has populated the graphics tag (delete the "old" .tif or .eps).
IF there is no <graphic> tag at the figure location in the manuscript (i.e., to insert a
new figure after author alterations),
THEN follow these instructions to insert a figure:
Make sure "Insert element" is open (View>Element List).
In "Insert Element", double-click on <figure> (or select and click "Apply").
Enter a unique identification value (IDREF) and hit "OK" (See also sheet titled "ID
Syntax").
Enter the correct RP graphic file name at the prompt.
Use the drop-down menus on the prompt to set the position of the figure (fixed or
floating (default is floating)) and the caption location (recto or verso (default is
recto)) if it's a full page figure.
Below are instructions to link a figure citation to the figure itself. See also section "Insert
an Internal Link".
Link the figure with the citation within the text by highlighting the citation (i.e.,
"Fig. 3b"), going to "Insert Element", double-clicking "intlink", and entering the
same IDREF as was entered for the figure above.
9.5. Cuts

Cuts have no caption and no linking within the text. The tagging for cuts can be either
exported from Word or inserted by the POs. The graphic file for a cut must be manually
inserted by the copyeditor prior to sending the file to layout.
Place cursor at location where cut should appear (within <para> or other tags).
Insert <cut> tags using "Insert Element List" (graphics tags will automatically
appear within <cut> tags).
Place cursor just after opening <cut> tag.
Enter a unique ID value in the Attribute Inspector.
Place cursor just after opening <graphic> tag.
Enter graphic file name (i.e., b06-123ca.eps) beside "fileref" in the Attribute
Inspector..

9.6. Show/Hide graphics

Graphics must be hidden to generate the PDF file. Hiding graphics also allows XMetaL to
process faster (i.e., when going back and forth between plain text view and normal view)
and may also allow for ease of reading.
Click on button

in RP article toolbar to show or hide graphics.

9.7. Full page graphics (resetting captions)

Captions for very large graphics will be placed by 3B2 (layout) on the facing page if
necessary. The following instructions will ensure that the caption is placed on the same
page as the graphic once the graphic is resized accordingly:
Send figure to graphics for resizing, to allow for the caption on the same page.
In XMetaL, change to "Tags On" view.
Put your cursor just after the <caption> start tag.
In the "Attribute Inspector", delete the floatloc value.
9.8. Broadside figures

The graphic for a figure that is to appear broadside should still be right way up.
Turn Tags On view.
Put your cursor inside the <figure> tag.
In the attribute inspector, set the "orient" attribute to "land" (for landscape).
9.9. Troubleshooting Figure Plates

Not all figures within a plate may be linked. To link each figure within a plate, place an
"intlink" tag around the figure citation in the text, making sure the IDREF attribute for the
"intlink" matches the ID of the <figure> tag.
9.10. Multimedia files

Edit caption for video "still" to refer to video on web site.
Change <figure> tag to <multimedia> tag.
Add <video/> tag after the <graphic/> tag.
Add fileref to the <video> tag for the actual video file
The fileref for the graphics tag should point to the video "still" in .eps or .tif format. This
should link automatically when you have opened the file in XMetaL, but you may need to
add it manually if it didn't link.
NOTE: to "view" multimedia files, you will need a media player. Contact T&R to have one
installed with manager's approval - http://zone.nrc-cnrc.gc.ca/infocisti/dir_tr/request/
service_e.html

9.11. Sponsors/Special graphics in idbox (i.e., Abbott logo)

Certain authors may have received sponsorship to complete their manuscripts. In these
cases (for example, the Abbott logo for APNM) it is necessary to add <sponsor> tags, as
follows:
Place cursor after final, closing <keywords> tag (after French mots-cles).
Use "Insert Element" list to insert <sponsor> tags.
Type sponsor text over replacement text.
Place cursor just inside opening <sponsor> tag.
Insert <special_graphic> tag from the "Insert Element" list.
Go to "Attribute Inspector" and enter fileref for graphic (for Abbott logo, this is
located at I:\XML\ADMIN\Special_graphics\Abbot_en.tif).
For additional lines of text:
Place cursor just after closing </sponsor> tag.
Insert additional <sponsor> tag using "Insert Element" list.
10. General editing
10.1. Troubleshooting out-of-order numbered citations (figures, tables, numbered references)

Extyles will generate a comment whenever out-of-order numbered citations are present in
the manuscript (for example, "Figure 3 comes before Figure 2 in the manuscript"). It is up
to the PO/copyeditor to correct these errors. It is important that all internal links be
correctly maintained whenever citation numbers are changed. To change citation
numbering, follow the instructions below:
Change text of caption, if applicable (i.e., "Fig. 3" to "Fig. 2") or reference numbers
in reference list.
Change text of citation while maintaining correct internal link IDref (check against
ID of target, or double-click to ensure it matches).
For figures, if the new figure caption number does not match the graphics file name,
ensure that the correct "fileref" (graphics file) is present for each figure caption by
manually entering the "fileref" name in the "Attribute Inspector". Contract editors
should insert a query to the PO, instructing them to manually fix the graphics fileref.
Change physical order of figures (including caption and graphic file), tables, or
references within the manuscript by clicking & dragging to new location (physical
order will affect HTML).
10.2. XMetal Spell Checker

It is not advised to use XMetaL Spell Checker, as it notoriously makes hundreds of
unknown, automatic changes to a document.

IF it is decided that Spell Checker is needed,
THEN follow these instructions PRIOR to EACH use of XMetaL Spell
Checker:
Select "Tools">"Spellchecker">Options"
Make sure "prompt before auto replacement" is selected.
NOTE: the above instructions may not work on CITRIX.
NOTE: always save a copy of your file prior to using spell checker.
11. Prepare file for production
11.1. HTML code "##"

WARNING! Two "number signs" back-to-back will be interpreted as an HTML code and
will result in errors in the HTML version of your manuscript. To correct this problem, try
ONE of the following steps:
If there are codes around both number signs, place them in separate tags (i.e.,
rearrange "<sup>##</sup>" to "<sup>#</sup><sup>#</sup>").
Try placing an empty query between the number signs (i.e., "#<query></query>#">).
Ask for help from XML staff.
11.2. Validate file

Certain changes to the document, particularly in "Plain Text View", may invalidate the
manuscript. Check that file is valid before creating pdf.
Click "Validate Document" button in toolbar or press F9.
To locate source of errors, double click error message in "Validation Log".
Correct all found errors (double-click on the error itself to take your cursor to the
location of the error in the document).
Double check that the manuscript is now valid by clicking "Validate Document"
button again.
11.3. Create PDF of manuscript

Switch to Normal View
Hide all graphics by using the

button.

Ensure comments (<query>) are NOT hidden (

).

Save As b05-019ms.xml
Go to "File>Print" at the top drop-down menus.
Select "Adobe PDF" or "Research Press".
When prompted, insert path to folder (i.e., "Originals" folder) in which the pdf will
be saved.

11.4. Number PDF file (OPTIONAL)

This section is optional. If you would like to number the PDF file, follow these instructions
(in Adobe Acrobat):
Go to "Document">"Security">"Show Security Settings".
Under the "Security" tab, make sure "Security Method" is set to "No Security".
Open "Pages" tab on far left of manuscript.
Click on "Options" at top center of "Pages" tab.
Choose "Number Pages".
11.5. Prepare file for layout

All track changes must be accepted and all bookmarks removed before the file is sent to
layout:
Go to "Tools">"Accept or Reject Changes".
Click "Accept all".
Click "Delete all bookmarks" icon in the "NRC RP" toolbar:
11.6. Additional instructions to layout

Place PHYSICAL FILE FOLDER on TOs desk to indicate that the manuscript is ready for
layout. This rule will avoid more than one person working on the XMetaL file at a time.
Print out pdf copy of tables for layout and indicate where to break table headings and if
there is any shading on the tables.
IF the manuscript contains equation in a table note or a figure caption (these
equations will have to be converted to TeX),
THEN fill out an "ms issue sheet" (G:\Publishing\Journals Program\RP Tech
Support\MS_issue_sheet.pdf) and attach to the file folder, and place the
folder directly on Judy Hum's desk.
11.7. Problems with layed-out file

Discuss first with layout staff.
If layout staff member cannot solve the problem, they should go to their team leaders
first for help.
For files that must go to Judy Hum directly, either layout or PO can fill out an "ms
issue sheet" (G:\Publishing\Journals Program\RP Tech Support\MS_issue_sheet.pdf)
and attach to the file folder prior to placing on Judy's desk.
12. Contractor edited files

12.1. Send file to contractors (editing in XML)

Ensure contractor has signed the agreement regarding use of NRC resources before
sending any XML files for editing (G:\Publishing\Business Group\Confidentiality and NonNRC Access Agreement Templates).
Also ensure contractors have received email (from Rebecca Simpson) regarding how to
access XMetaL using CITRIX.
Copy exported file and name one copy with extension $export (i.e., x06-001$export.
xml).
Send file with original manuscript name (i.e., x06-001.xml) to contract editors by
following instructions below.
Check that the R: drive is mapped to \\Dove\osprey\s20-restore\COPS contractors and is
available on your computer. If it is not, contact Stive Simard to set up this drive for you.
Copy only the XML file from location on I: drive.
Place cursor in R: drive, in folder labelled with name of contractor.
Paste the XML file in the R: drive (do not place figures or other files in this
location).
Send any other relevent files (i.e., pdf file) via email or ftp. Do NOT send figures.
12.2. Receive file from contractor (edited in XML)

Make copy of returned file with contractor's initials (i.e., x06-001ab.xml) and place
in "Originals" folder.
Open in XMetaL to populate figures before sending to layout.
Review editing and make any further changes using Track Changes.
13. AAs
13.1. Make changes and save backup of file with AAs entered

Make all text-based and math changes to the manuscript in XMetaL (layout are
responsible for moving frames, moving tables, etc.)
"File>Save As" with suffix "$AA" (e.g., b05-017$AA.xml).
Close that file and move to Original folder
NOTE: see section titled "Reference linking to databases" if any changes and (or)
additions have been made to the reference section.
13.2. Setting webdate

Either the PO or the layout technician can enter the webdate; it will be entered by whoever
has the paper when the webdate decision is made.
Switch to "Tags On" view.

Put your cursor after the last closing </date> tag (in "Administrative information" at
the top of the manuscript).
Insert <date> from the "Insert Element" palette list.
Place cursor immediately after opening <date> tag or immediately before closing </
date> tag.
In the "Attribute Inspector" palette, set the datetype to "webpub".
Enter the day (one or two digit number), month (one or two digit number - do not
enter "0" before number; i.e., March = "3", NOT "03"), and year (four digit number)
into their respective tags.
13.3. Setting paper version (unpaginated vs. paginated)

Either the PO or the layout technician can set the document stage to unpaginated or to
final.
Click the RParticle information button

.

Select the "Paper version" (proof, unpaginated, or final) from the drop down list
("final" will ensure the document is paginated upon layout).
Click OK.
14. Approving web files
14.1. Approving file for the web

Notify the Web technician that a new issue needs to be opened (taken off "hold") by
checking the appropriate box on the white sheet stapled to the folder.
Move all non-working files to "Originals" folder.
NOTE: do not overwrite "XXX-XXX$edited.xml" file if prompted - delete all but the initial
(earliest version) "XXX-XXX$edited.xml" file.
Once each manuscript has been approved, let layout know so that they can create the
GIFs and final web PostScript.
Move manuscript folder to L:\Prod\{journal/vol/iss}.
Move XML file from the manuscript folder to the issue level folder.
Give hardcopy folder to the web technician (if desired, force publication before this
step).
14.2. XML to HTML Publishing System: Overview and Definitions

The COPS XML to HTML publishing system is located at http://rparticle.web-p.cisti.nrc.
ca/rparticle/index.cps; functions can also be accessed via the COPS Toolbar (install by
double-clicking G:\Projects\Cops\XSL\toolbar\copsprodsetup.exe).

Here is a basic definition of the functions available on the XML to HTML publishing
system:
Publish: converts document on L: drive from XML to HTML. Precursor to use of
other available functions listed below.
Preview: allows user to view the HTML document. Select either HTML, Printable
HTML, Abstract, or pdf.
Remove: allows removal of manuscript from HTML system; use before republishing
new version of manuscript to remove old version with same name (i.e., remove
unpaginated version, republish paginated version; see below for further instructions).
Approve: once file has been previewed and is ready to go live (approved by both
Web Technician and PO). It will then release on the webpub date.
14.3. Checking full-text HTML

You will receive an email from the automated publishing system with a link to the file to be
proofed. The link in that email will take you to the full-text HTML version. From there you
can link to the version with full-sized figures using the button at the top; you can link to the
PDF version using the button in the sidebar; you can view the Summary Page by clicking
on the link in the sidebar. To return to the HTML after viewing the Summary Page, click on
Preview>HTML in the COPS toolbar and enter the manuscript number.
When you receive the folder from the web technician indicating they have approved
the file, click on link in email from automated publishing system.
Check that content matches that of approved PDF file. See HTML proofing checklist
for reference.
IF there is an error in the file that is a result of an XML error,
THEN The file needs to be removed and moved back to the I drive to correct
the error:
Click on the Remove button in the COPS toolbar or go to http://rparticle.web-p.cisti.
nrc.ca/rparticle/remove.cps.
Type in the manuscript number into the "msno" field.
Click "Remove Article".
Note: you may get a message that says "You have already submitted this form"; Refresh
your browser, then go back to the Remove page using the Remove hyperlink not the

toolbar

and try again.
On the L: Final drive, move XML file (e.g., b05-096.xml) back into the manuscript
folder (e.g., L:\Prod\cjb\cjb8309\b05-096).

Move the entire manuscript folder back to the I: drive (e.g., I:\XML\cjb\cjb8309
\b05-096).
Make the correction to the file.
IF the change affects the print version or the web gifs,
THEN send the XML file to Layout with instructions.
Request a change in the webdate if necessary.
Move the files back to the L:\Prod drive.
Move the XML file out to the issue level folder.
Wait for email notification that it's been republished.
IF you don't want to wait for the system to republish the file,
THEN Use the Web interface to republish:
Click on Publish button in the COPS toolbar or go to http://rparticle.web-p.cisti.nrc.
ca/rparticle/publish.cps.
Enter the manuscript number in the "msno" field.
Click on "Publish Article".
IF the file is ready for approval (both Web technician and PO have approved),
THEN Approve the file:
Click the Approve button on the COPS toolbar or go to http://rparticle.web-p.cisti.
nrc.ca/rparticle/approve.cps.
Enter the manuscript number in the "msno" field (this may already be populated if
you were just previewing that manuscript).
Click "Approve Article".
14.4. Reloading Paginated Paper

On the L: Final drive, move XML file (e.g., b05-096.xml) back into the manuscript
folder (e.g., L:\Prod\cjb\cjb8309\b05-096).
Move the entire manuscript folder back to the I: drive (e.g., I:\XML\cjb\cjb8309
\b05-096).
Either manually enter pagination and sequence or give to layout to add pagination
and sequence.
To enter pagination manually in XMetaL:
Place cursor right after opening <rparticle> tag at top of manuscript.

Calculate the starting and ending page numbers.
In the Attribute Inspector, set the "startpage" and "endpage" values to the starting
and ending page numbers, respectively.
In the "Administrative Information" box at the top of the manuscript, enter the
sequence number between <sequence> tags. (NOTE: Include all front matter
when determining sequence; i.e., the first paper may be item number 3 rather than
1).
Send the XML file to Layout with instructions.
Once approved, move the electronic files back to the L:Final drive.
Move the XML file out to the issue level folder.
Click on the Remove button in the COPS toolbar or go to http://rparticle.web-p.cisti.
nrc.ca/rparticle/remove.cps.
Type in the manuscript number into the msno field.
Click "Remove Article".
Use the Web interface to republish.
Click on Publish button in the COPS toolbar or go to http://rparticle.web-p.cisti.nrc.
ca/rparticle/publish.cps.
Enter the manuscript number in the "msno" field.
Click on "Publish Article".
IF the file is ready for approval,
THEN Approve the file:
Click the "Approve" button on the COPS toolbar or go to http://rparticle.web-p.cisti.
nrc.ca/rparticle/approve.cps.
Enter the manuscript number in the msno field (this may already be populated if you
were just previewing that manuscript).
Click "Approve Article".
14.5. Correction after posting

Follow these instructions for correction after posting:
Open manuscript.
Make corrections to manuscript.
Place cursor just inside closing </back> tag.
Using the "Insert Element" palette, insert <corr-after-posting> tags.
Insert text (if applicable, figures, equations, tables, etc.) describing correction(s).

Place cursor just after closing </date> tag in "Administrative Information" (at top of
manuscript).
Insert another set of <date> tags using "Insert Element" palette.
Place cursor just before the new opening or closing <date> tag and select one of the
following "datetype" attributes from the "Attribute Inspector" list:
"reposted-corr" will output this text: "Reposted on the Web site with correction
on (date)".
"reposted-corrs" will output this text: "Reposted on the Web site with corrections
on (date)".
"reposted-add" will output this text: "Reposted on the Web site with addition on
(date)".
"reposted-adds" will output this text: "Reposted on the Web site with additions on
(date)".
Republish the file normally (the "correction after posting information" will be used
to create the separate correction page on the web)
15. Front matter and other papertypes
15.1. Creating front matter

These instructions are for creating the following: announcement, introduction, editorial,
editorial-policy, commentary, discussion, letter, foreword, guest-commentary, memoriam,
obituary, preface, tribute.
Open XMetaL Author.
Go to File>New (or use toolbar button).
Under the General tab, select "Front matter".
"Save As" on I: drive in appropriate issue folder with manuscript number as the
filename.
Change to "Tags On" view.
Put cursor after <rparticle> tag.
Set journal name in "Attribute Inspector" using drop-down list.
Put cursor after <communication> tag.
Set paper type (category) in "Attribute Inspector" (i.e., introduction, announcement,
editorial, etc.).
Fill in necessary "Admin information" (copyright year, citation information, cover
date, manuscript number).
Enter title between <mtitle> tags if applicable. If there is no title, these tags cannot
be deleted, so just leave them blank.
Enter English content (cut and paste from Word file if need be) between <content-

en> tags.
Enter author name and title (i.e., Editor) between relevent tags if applicable.
DELETE any unused tags (blank tags will cause extra spaces in layout if not
deleted).
To add French content:
Ensure content has been properly exported from eXtyles by EAs (tell EAs to
process as they would a batch-processed résumé).
Cut and paste exported text between <content-fr> tags.
15.2. Create errata

These instructions are for creating an erratum, corrigendum, retraction, or addition and
correction.
Open XMetaL Author.
Go to File>New (or use toolbar button).
Under the General tab, select "Erratum".
"Save As" on I: drive in appropriate issue folder with manuscript number as the
filename.
Change to "Tags On" view.
Put your cursor after the <rparticle> tag.
In the attribute inspector, use the drop-down lists to select the appropriate journal
name and to set the article type (i.e., corrigendum, erratum, retraction, etc.).
Fill in necessary "Admin information" (i.e., copyright year, citation information,
cover date, manuscript number).
Put your cursor in front of the closing admin tag . From Insert Element, select
assocpapers. Now select referring-paper from Insert Element. Enter the control
number of the original paper beside “Manuscript number:”. In “Citation
information”, insert text in the journal, volume, issue, start page and end page tags,
using information from the original paper. See section on “Associated papers” and
“Referring papers” elements for more details.
Put your cursor inside the <title> tags and insert the title of the original paper. The
title should be preceded by "Erratum".
Enter author information by typing text between relevent tags (Note: <sequence>
tags indicate which author will be first, second, etc., so type in "1", "2", etc., for each
author (Note: first name and middle name tags can be entered by placing cursor just
in front of <lname> tag and selecting <fname> or <mname> from "Insert Element"
list)) OR by copying and pasting <author> tags and contents from original
manuscript (click on <authors> in original paper to select and copy. In an erratum,
click on <authors> to select and paste). If re-keying the text, make certain you fill in
the affiliation and corresponding author information (should appear as it does in the
original paper). See section 4. Edit author information for further details.

Enter Ref.: statement between <refstatement> tags.
Enter text between <para> tags. The first sentence should explain the reason for the
erratum. Tables and figures should be inserted within the same <para></para> tag as
the explanation text. They can be copy and pasted or entered manually, depending
on the nature of the change. You may have to get your table re-eXtyled. The same
applies to text and equations. Equations will have to be tagged with <equation></
equation> tags. See section 5. Edit Math for more details about equations.
15.3. Publish front matter

Front matter won't be published automatically once in the L: drive, because these
manuscripts do not go up as HTML. Follow these instructions to publish all front matter:
Move files to L:/Final directory.
Notify web staff that front matter is in the L:/Final directory drive; include the
manuscript number.
Web staff will manually enter the metadata into Oracle and copy the PDF to the web
server.
IF the automated system tries to access the file before the web staff, an error
message may be generated. This error message can be ignored.
When you receive an email from the web staff, proof the PDF on the web and
approve for release.
15.4. Associated papers

These instructions are for companion papers, discussions, replies, errata, etc.
Place cursor just before closing </admin> tag in box at top of manuscript.
From "Insert Element" list, select <assocpapers>.
Insert element relating to type of manuscript from "Insert Element" list (i.e.,
<discussion>, <companion>, etc.)
Fill in text or attribute information.
15.5. Running heads for companion papers

Companion papers are distinguished by placing a roman numeral after the author's name
in the running head (i.e., Smith et al.: I and Smith et al.: II). Below are the steps to include
this roman numeral:
Place cursor just before closing </admin> tag in Administrative Information box at
top of manuscript.
Using "Insert Element" tool, insert <run-head> tags.
Insert the proper running head text (per RP style) between the <run-head> tags (i.e.,
<run-head>Smith et al: I</run-head>).

